Error uploading photos

Discussion in 'Forum Information and Issues' started by Yorkshire Dave, 3 October 2017.

  1. Yorkshire Dave

    Yorkshire Dave Western Thunderer

    Hi

    I have recently encountered this error over the last few days when trying to upload photos.

    It just says there was a problem but it does not say what the problem is.

    It is file size (I usually try and keep this below 350Kb where I can), server problem or internet provider problem.

    Any explanation gratefully received.

    error.jpg
     
  2. Heather Kay

    Heather Kay Western Thunderer

    I've been seeing this, too.

    I'm using an iPad, the Safari browser, currently running iOS 10.3.3.

    The cure seems to be to reduce the image pixel size.
     
  3. Yorkshire Dave

    Yorkshire Dave Western Thunderer

    Thanks Heather. This is the only item I haven't looked at. I've reduced the file size but not the image pixel size. I'll give this a try.
     
  4. adrian

    adrian Flying Squad

    It's not just the physical size but the limit is also 1500 x 960 pixels.(width x height). If you are still having problem then email me a sample image and I'll double check what I can.
     
  5. Heather Kay

    Heather Kay Western Thunderer

    Most snaps I take for my thread posts are done with this iPad camera. Until recently, the forum has uploaded them pretty much without incident, save for the occasional image that is perhaps slightly larger in file size due to rather more complexity in the image being encoded into the JPEG.

    When that happened in the past I would alter the default pixel size (I use Pixelmator iOS for this, as it's not possible as far as I can see using Apple's Photos app) to something a fair deal smaller. From memory, the default image size is something like 2500 pixels wide or thereabouts. Today, with the upload error, I found 1800 pixels uploaded fine.

    Images shot with the slightly more recent iPod touch camera, which is higher resolution than my iPad mini, always need to be resized before they can be uploaded here.

    All of which is to say something has changed at the forum end which is throwing its toys out of the pram when confronted with an image size that was fine a few days ago. Why is anyone's guess, but if anyone can find out it'll be @adrian :)
     
  6. oldravendale

    oldravendale Western Thunderer

    I've just had this with the upload of the pic of the Light Pacific and Standard 5. Normally the message is that the file is too large, but this time it just said that there's a problem. I halved the file size and it loaded fine.

    B
     
  7. adrian

    adrian Flying Squad

    I'm not aware of anything that has changed, but something seems to have. So I will check and get back to you.
     
    Heather Kay likes this.
  8. FiftyFourA

    FiftyFourA Western Thunderer

    Adrian,

    I had the same message earlier today, but it still uploaded the photo anyway without me doing anything more. I thought it was just having a 'strop', like a teenager!

    Peter
     
  9. adrian

    adrian Flying Squad

    Hi,

    I've done a little digging and yes something seems to have gone wrong Friday morning about 11am. Any large photos uploaded should be automatically resized to the 1500 x 960 pixel size for the forum as I indicated earlier. However the server logs are reporting an error saying that the 33Gb memory has been exhausted uploading a 4.5Mb image file, the system says I'm only using 55% of the memory so by my reckoning there should be ~15Gb memory free to upload the image.

    I have contacted the hosting company I use to ask them to check the server. It maybe that one of the other users has some run away process hogging all the memory. They are usually very good with the support, they are a local company to me and not some offshore call centre in a different time zone. :thumbs: So I hope to have an update for you in the morning.

    In the meantime - if you do get problems like this then please flag it up to me as soon as possible I don't mind being pestered if it keep the forum ticking along smoothly - it doesn't matter how small but if I don't know about the problem then I'm not going to chase it up.
     
  10. adrian

    adrian Flying Squad

    Yes it seems to be a memory problem on the server, as the memory usage fluctuates the error may randomly appear. So sometimes it'll work and sometimes it won't. I've asked the hosting company to investigate.
     
    chrisb likes this.
  11. Yorkshire Dave

    Yorkshire Dave Western Thunderer

    Thank you for investigating Adrian. In the meantime I'll reduce the pixel size 1500 x 960.
     
  12. Ian@StEnochs

    Ian@StEnochs Western Thunderer

    I got the same message with the picture I loaded yesterday. Twice it was rejected but loaded fine on the 3rd attempt without me changing the size of the photo.

    Ian.
     
  13. oldravendale

    oldravendale Western Thunderer

    Thanks for your efforts on our behalf, Adrian.

    B
     
  14. adrian

    adrian Flying Squad

    Hi,

    Thanks for flagging this up - having contacted the hosting company it appears that they had "improved" the backend server software on Friday morning. It does actually make things easier to manage but without going into the technical details the "upgrade" reverted certain bits of software to the standard defaults, one of which limited the file upload to 2Mb.

    So I have altered the settings to increase the file upload limits, this is why it is better in that I can modify certain settings myself rather than having to ask the hosting company to do it on my behalf. It seems to work in the test area so I've made the changes here.

    If somebody could try one of the problem images and let me know if it works now then I'd appreciate it.

    Adrian
     
    mickoo likes this.
  15. Heather Kay

    Heather Kay Western Thunderer

    I just tried a selection of photos, and they all uploaded properly. I haven't bothered to include them in this post, and have deleted them again.

    Thanks for looking into this, Adrian. It's the hidden back office work of keeping a forum ticking along that often goes unnoticed out here. It is much appreciated.
     
  16. oldravendale

    oldravendale Western Thunderer

    What Heather said! Thanks Adrian.

    B
     
  17. Yorkshire Dave

    Yorkshire Dave Western Thunderer

    Again, what the others have said. Thank you for resolving the issue Adrian.