Weaver Geep DCC running problem - help please!!

Discussion in 'Techniques' started by Jordan, 14 May 2020.

  1. Jordan

    Jordan Mid-Western Thunderer

    This is a real mystery, this one....

    I have a Weaver O Scale Geep, 2-rail, Pittman motor, shaft drive via delrin chain on a tower to rear axle, then shaft drive to all axles.

    A few years ago I fitted a 'boosted' Soundtraxx Tsunami 3amp dcc decoder to it, and all was well and good until last year, when the loco started behaving strangely - when the speed was set, at anything above speed step 1, the loco would get to that speed, and utterly ignore any further commands, like slowing down, stopping, etc. It just kept going regardless.

    I thought maybe the decoder was at fault - I've found Tsunami's to be fussy things, liable to stutter at random, on clean track that other decoder-equipped locos go through no problem.

    So I've replaced the decoder with an ESU Loksound L, again 3amp rated.... and the same 'runaway' problem is occuring. While "in between" decoders I wired it for DC and tried it on analogue - no problems at all. I've checked the wiring and pickups for any sign of breaks or shorts - all looks ok, and it doesn't trip the system anyway, which is NCE Powercab with NCE 5 amp booster. Cleaned the wheels, including the rear faces that the pickups contact.

    Then I've tried it with a similar motor (Pittman). Same runaway issue, so it isn't a motor fault, BUT - here's what's really mystifying - with the drive shaft disconnected, i.e. no load on the motor, it behaves itself ok. Starts, stops, reverses, all according to throttle settings.

    Re-connect the drive shaft, and it misbehaves again. The fact it's done it with two different decoders, that were both new, and have even had CV8 reset by me just in case, leads me to say it's not a faulty decoder either, but clearly something is happening when the motor is under load that is scrambling the decoder signals. The drive train does not bind or catch, there's some slack in it, and with everything connected up it all turns easy enough by hand.

    I'm utterly at my wit's end with this issue. Anyone come across anything like it before??? Or any ideas what might be happening??

    Photos show the loco innards, minus speaker, excuse the slight rats nest of wiring, also shows the driveline (disconnected from the motor).

    20200514_213511.jpg
    20200514_213504.jpg
    20200514_213431.jpg
    20200514_213423.jpg
     
  2. richard carr

    richard carr Western Thunderer

    Hi Jordan

    Looking at that I'm not sure that 3 amps is enough, do you have a large speaker attached as well ?

    I have Heljan Class 128 parcels DMU, I tried to get away with a small decoder and a big speaker and it behaved as you describe above, the speaker was the problem once I got rid of that and used a more modest one that the decoder could power it has been fine.

    In your case though I could see that a large motor like that with all the drive shafts is going to draw a lot of current do you have a ramp meter to measure it ?

    Have you got a bigger decoder that you could try it with ?

    Richard
     
  3. Steph Dale

    Steph Dale Western Thunderer

    Jordan,
    3A is probably a bit marginal, as Richard says. My second thought after that is to set CV29 to digital-only operation. Mechanically, it looks okay - I've got some bits here to ball-race and belt-drive Weaver mechanisms to lower the friction if you really get stuck: That would reduce noise and current demands, but I don't know how far that would help. Worth noting that @Yorkshire Dave has a Red Caboose GP running with one of those big Pittman motors with an ESU 'L', but the Atlas drive is appreciably less sticky than that from Weaver (I have both types here). Of course, the motors might not be the exact same type, but even then the extra friction can't help.

    It'd be interesting to know the current draw and whether sorting out CV29 helps.

    The decoder reset was worth doing, just in case there was an errant setting somewhere. I do that on installation as a matter of routine.

    Steph
     
  4. Yorkshire Dave

    Yorkshire Dave Western Thunderer

    Hi Jordan

    I agree, it's not a decoder issue and as Steph has mentioned I use a Loksound L decoder to drive a Pittman motor and two speakers in a Red Caboose GP9.

    I'll hook up my spare Loksound L to a Weaver drive loco over the weekend to see what happens and report my findings.

    I would have checked what you have already checked and a few more:
    Have you tried operating the loco on an isolated section of track not connected to the layout?
    Are you able to disconnect the lead truck and try the decoder with the rear drive truck to see is that works satisfactorily?

    Other things I would also check for if you have the loco apart are split gears in the gearboxes as I've had weaver gears split and the drive shaft connection, again I have one split and is held here with a cable tie.

    U23B 025.jpg
     
  5. Jordan

    Jordan Mid-Western Thunderer

    Thanks for all the replies, it does all seem to point to the drive line needing too much power.
    I don't have a 'ramp meter' (???) but I'll try the Powercab without the booster, as it can give an Amp reading when set up 'by itself'. A reading with & without drive connected will be an interesting comparison.
    There is a large(ish) speaker but it makes no difference to the behaviour connected or not.
    I always set CV29 as 'DCC only' - something I read of as being good practice, and I don't need to run my US stuff on any DC layout anyway.
    I have a Red Caboose GP9 which until now remains analogue only. (It hasn't run in a while!! :( ) Due to the Atlas drive I wasn't planning to fit sound, but have a large Lenz chip to fit. It's a similar Pittman motor so I must get round to fitting it & see what happens.
    As the 3 Amp Tsunami was fine when first fitted in this Weaver Geep, but running went erratic some time last year, I'm thinking that the driveline lubrication must be in need of attention.
    I hope that's the issue as I have another Weaver Geep slowly being worked on that I have another Loksound L waiting for.
    As I understood it the Loksound L was developed for O as it's smaller than the XL, to fit in narrow-hood locos, and 4 or 5amp decoders were overkill for a lot of O Scale locos. Maybe that didn't include Weavers!!??
    Thanks again everyone.