Laser cut timbers from Templot dxf

Discussion in 'Permanent Way' started by NewportRod, 12 November 2021.

  1. NewportRod

    NewportRod Western Thunderer

    A number of companies are offering services where they cut ply placed on the output from Templot. This is an excellent service which I've used in both 4mm and 7mm and saves a lot of time. I have just noticed a little "design feature" that some of modellers, especially those working in the pre-grouping era might like to be aware of.

    When I drew the plan on Templot I, perhaps naïvely, thought that all I was have to do to ensure that the sleeper length was set to 9’ and everything would be ok. And indeed the TIMBOUTL layer (dark blue here) does reflect a sleeper length of 9’.

    upload_2021-11-12_15-14-33.png


    But, I hadn’t taken account of another layer on the plot, SLEEPEND seen here in red, which puts a line across the sleeper 3” inboard of the end.

    It appears that the cut for Crindau Pill used the SLEEPEND to define the sleeper length rather than TIMBOUTL so I’ve ended up with 8’6” sleepers, not the desired 9’.

    upload_2021-11-12_15-17-54.jpeg

    In the pic above you can see 8'6" sleepers I got (those with chairs) alongside the 9' length I had hoped for.

    I expect that deleting the contents of the SLEEPEND layer might be a satisfactory workaround but I cannot verify that, though I imagine a chat with the laser-cutting service provider will come up trumps.

    I'm not writing this with any criticism of any of the companies that provide laser-cutting services, nor indeed plot, whom I believe never intended to be used in this way .
     
    BrushType4, simond and daifly like this.
  2. martin_wynne

    martin_wynne Western Thunderer

    @NewportRod

    Hi Rod,

    It certainly is intended to be used that way. But why-oh-why don't folks get involved on the Templot Club forum and keep track of developments? For the last 3 years I have been making many, many changes to the DXF output in connection with 3D printing and laser-cutting:

    dxf_sleeper_ends.png

    However, there isn't actually any change to the feature you mentioned -- it's been unchanged for 20 years. If you don't want a layer in the file, set the colour to None, or blank, or right-click on the colour. See above.

    You are also exporting the timbers with outline extension marks, which will upset the laser-cutter. There are options for that:

    dxf_kerf.png

    Switch timber outlines off, and timber outlines (kerf) on. You can then set the required cutter kerf offset on the button (or zero if the laser-cutter firm request it), and the outline extension marks will be ignored.

    Lots more about all this stuff at:

    Plug Track

    laser_cut_timbers.jpg

    [​IMG]

    [​IMG]

    [​IMG]

    cheers,

    Martin.
     
  3. NewportRod

    NewportRod Western Thunderer

    Thank you Martin,

    I had obviously overlooked that setting in Templot - and also the second chance I had to avert the problem in the dxf file. I'm not blaming anyone other than myself; in making this post I just wanted to avoid others making the same mistake.

    Your ongoing developments are very interesting and I wonder how far things will have progressed by the next time I get to lay some track.

    Cheers
    Rod